Confluence 5.8.4 crashing unexpectedly?

Published:
1 minute read

We utilise Atlassian Confluence for our internal wiki.

Overall we find it to be the wiki market leader, but we recently had some issues with some unexpected server crashes after installing Confluence 5.8.4.

After some investigation and feedback from Atlassian, it turned out to be a bug with the built in JRE (build 1.8.0_45-b14).

The workaround for now is to install a pre-release JRE (build 1.8.0_60-b21) which you can get from here.

Take note, ensure that when you install the new JRE, that you set the destination folder to the confluence\jre folder of your Confluence instance. This is required to override the built in JRE location utilised by Confluence, therefore replacing the buggy 1.8.0_45-b14 with the fixed 1.8.0_60-b21.

NOTE: If you use the system JRE for your confluence instance, then obviously ignore this section!

Click on Change Destination Folder

Click on Change and set the Confluence\jre folder to your location then click on Install.

That is all that is required. Restart your confluence service and you should not the crashing issues again.

We will have to wait for a new version of Confluence that has the officially released from Oracle JRE that has the fix to get past this workaround. (and no, the just released version 5.8.5 does not have it yet)

Leave a Comment